Oct
19
2009
0

Citrix Web Interface, CSG and Windows 2008 NLB

Citrix Logo

So i wanted to update to the new web interface from 4.6 to 5.2. I also wanted to use 2008 servers with NLB, couldn’t make it work with 4.6 and server 2003. So i took 2 new servers and did a fresh install. I got the web interfaces configured so that they worked properly, and installed Citrix Secure Gateway on each of the WI:s. Then came the fun part to get the NLB working.

To get windows NLB working at all, all the servers has to be on the same subnet and there cant me more than 32 servers in the cluster.

I’m using multicast since i only have a single network card on the servers and my network infrastructure supports it, which many different routers aren’t, since you are having 2 mac:s on a single nic. If i had nics i would use unicast. One nic for administrating and one nic for the cluster.

And i specify the NLB address on the same subnet as the two servers. And using the default port rules which is basically saying to use nlb on all ports.

Next step is to configure the CSG, in which I’ve already has configured the basic settings, certificate, ssl and so on. But i need the change the monitoring of inbound connections where i specify the CSG to listen on the NLB address. And ofc do this on both WI/CSG servers.

And that’s it. Now i have a working NLB on my Citrix Web Interface.

On an another note i discovered i couldn’t force ssl in the IIS otherwise it gave me errors when the csg used http to fetch the web pages from the iis and then presenting them as https.

Powered by WordPress | Aeros Theme | TheBuckmaker.com WordPress Themes